By using an object oriented approach, it helps to reduce this problem..
connectionsToAccessLines -> connexion.connect(System.getAccessLines());
handleWallVisionSplit -> this one, I'm not really sure what it does :D
But, I'd say something like: wall.handleVision(Wall.split); or whatever, I think you understand what I mean.
Also, sometimes, when it's really hard to name a too specific function, it can be because the code isn't enough high level. For instance:
readSecondWordOfLine(a_line) -> line.split()[1].
Or, sort(sortWithSecondWordOfLine()) could become, sort(line=>split(line)[1]).. I know it's not always doable as clean as that in all languages, but you get my point. With C++, for example, you can use bind and stl composites to build one liner expression instead of creating a new method.
So, I could summarize that by saying, if you have a too technical method - which is usually really short because otherwise the name would be easy to find by abstracting the functionalities- it's good to create a new function/class more generalized with an abstract name and use it directly in the first function.