Hi,
When i work in VS2008, i use the Ctrl+K+D very often as it saves a lot of time.
But in CSS files, this command formats the document in a way i don't quite like.
For example when i auto format the document,
.Foo
{
width:1px;
height:2px;
}
However, i like to format tags this way, as it is much more easy to read (in my opinion):...
The more I browse the code to open source projects in languages that aren't Python, the more I realize that it seems a lot of programmers don't believe in proper indentation. (I won't mention any projects specifically to avoid having anyone take this question too personally.) Usually code is indented, but in a way just different enough...
Hello, everyone!
I have a project (related to graph algorithms). It is written by someone else.
The code is horrible:
public fields, no getters/setters
huge methods, all public
some classes have over 20 fields
some classes have over 5 constructors (which are also huge)
some of those constructors just leave many fields null
(so I can'...
I know that the following works but it is not that readable, is there any way to make it more readable in the code itself without the addition of a comment?
//Start her off
String sampleregex = "\\\\";
if (input.matches(sampleregex))
//do something
//do some more
...
I have an ICollection<MapNode>. Each MapNode has a Position attribute, which is a Point. I want to sort these points first by Y value, then by X value, and put them in a multidimensional array (MapNode[,]).
The collection would look something like this:
(30, 20)
(20, 20)
(20, 30)
(30, 10)
(30, 30)
(20, 10)
And the final product:
(20...
I have some code that works on the color structure like this
public void ChangeColor()
{
thisColor.R = thisColor.R + 5;
}
Now I need to make a method that changes a different variable depending on what it is passed. Here is what the code looks like now.
public void ChangeColor(int RGBValue)
{
switch(RGBValue)
{
c...
I have these long statements that I will refer to as x,y etc. here.
My conditional statements' structure goes like this:
if(x || y || z || q){
if(x)
do someth
else if (y)
do something
if(z)
do something
else if(q)
do something
}
else
do smthing
Is there a better, shorter way to write th...
for (;;) {
//Something to be done repeatedly
}
I have seen this sort of thing used a lot, but I think it is rather strange...
Wouldn't it be much clearer to say while (TRUE), or something along those lines?
I'm guessing that (as is the reason for many-a-programmer to resort to cryptic code) this is a tiny margin faster?
Why, and ...
I've been told that there is some overhead in using the Java try-catch mechanism. So, while it is necessary to put methods that throw checked exception within a try block to handle the possible exception, it is good practice performance-wise to limit the size of the try block to contain only those operations that could throw exceptions.
...
This is not a homework ;)
I need to both A) optimize the following code (between a TODO and a ~TODO) and B) convert it to [P]Linq. Better readability is desired. It might make sense to provide answers to A) and B) separately. Thanks!
lock (Status.LockObj)
{
// TODO: find a better way to merge these dictionaries
foreach (KeyValue...
I've been at my very first programming job for about 8 months now and I've learned incredible amounts so far.
Unfortunately, I'm the sole developer for a small startup company for internal applications.
For the first time ever though, I'll be handing off some of my projects to someone else when I leave this job. I've documented all my...
sqlInsertFrame.Parameters.AddWithValue("@UserName", txtUserName.txt);
Given the code above...if I don't have any need to move the textbox data into a string variable, is it best to read the data directly from the control?
In terms of performance, it would seem smartest to not create any unnecessary variables which use up memory if it...
Take the following pseudo C# code:
using System;
using System.Data;
using System.Linq;
using System.Collections.Generic;
public IEnumerable<IDataRecord> GetRecords(string sql)
{
// DB logic goes here
}
public IEnumerable<IEmployer> Employers()
{
string sql = "select EmployerID from employer";
var ids = GetRecords(sql).S...
This is a very open question, but I think it can be very beneficial for SQL readability.
So you have a Java program, and you are trying to call a monster SQL statement from it, with many subqueries and joins. The starting point for my question is a string constant like this:
static string MONSTER_STATEMENT =
"SELECT " +
" fiel...
Sequential Asynchronous calls are gross. Is there a more readable solution?
The problem is this is hard to follow:
ajaxOne(function() {
// do something
ajaxTwo(function() {
// do something
ajaxThree()
});
});
where the anonymous functions are callbacks that are called on server response.
I'm using a third party API to ...
I'm a java programmer, but now entering the "realm of python" for some stuff for which Python works better. I'm quite sure a good portion of my code would look weird for a Python programmer (e.g. using parenthesis on every if).
I know each language has its own conventions and set of "habits". So, from a readability standpoint what are c...
You'll appreciate the following two syntactic sugars:
lock(obj)
{
//Code
}
same as:
Monitor.Enter(obj)
try
{
//Code
}
finally
{
Monitor.Exit(obj)
}
and
using(var adapt = new adapter()){
//Code2
}
same as:
var adapt= new adapter()
try{
//Code2
}
finally{
adapt.Dispose()
}
Clearly the first example in each case is more readable. ...
Hi !
I love doctests, it is the only testing framwork I use, because it is so quick to write, and because used with sphinx it makes such great documentations with almost no effort...
However, very often, I end-up doing things like this :
"""
Descriptions
=============
bla bla bla ...
>>> test
1
bla bla bla + tests tests test...
What have you found to be the best way to format your ASP.NET markup files (aspx, ascx) for readability? Any tips and/or tricks?
I'm looking for comments on indentation, line-wrapping, naming schemes, <%-- --%> commenting, or whatever you can think of.
...
This code trims whitespace, (fyi: it's credited to be very fast)
function wSpaceTrim(s){
var start = -1,
end = s.length;
while (s.charCodeAt(--end) < 33 ); //here
while (s.charCodeAt(++start) < 33 ); //here also
return s.slice( start, end + 1 );
}
The while loops don't have brackets, how would i correctly add br...