A famous computer scientist, Edsger Dijkstra, once remarked, "Computer Science is no more about computers than astronomy is about telescopes." I am inclined to agree. However, this brings up an interesting question: what would a better name for the field be?
...
When I use A.column name, B.Column name where A = Table A and B = Table B , what is the technical name for the A.Column name? Is it a prefix, identifier or what else?
...
I was fooling around with some functional programming when I came across the need for this function, however I don't know what this sort of thing is called in standard nomenclature.
Anyone recognizes it?
function WhatAmIDoing(args...)
return function()
return args
end
end
Edit: generalized the function, it takes a variabl...
if digit is the name for a number on base 10, what would be the name for a number on base 16? Hexgit?
...
I find that I frequently end up writing a function that I always call "clamp()", that is kind of a combination of min() and max(). Is there a standard, "canonical" name for this function?
It always looks something like this:
function clamp($val, $min, $max)
{
if ($val < $min)
return $min;
else if ($val > $max)
return $max;...
Perhaps it isnt even a DAG, but as its naming im after i wasnt sure what title to give this...
What is the name of a data structure where every node can only have 0 or 1 paths INTO it?
Strictly, is this a tree?
Thanks
...
one of the things i like most about cocoa is the readability factor.
but...
one of the things that annoys me most is the convention of convenience constructors to stutter.
what I mean is this:
[NSString stringWithString:s]
[NSNumber numberWithDouble:d]
[NSValue valueWithInt:i]
[NSDictionary dictionaryWithObjectsAndKeys:]
etc...
...
After-the-dot-in-a-file-name, it is called extension.
...
Quick question: I'd like to hear your thoughts on when to use "State" versus "Status" when naming both fields such as "Foo.currentState" vs "Foo.status" and types, like "enum FooState" vs "enum FooStatus". Is there a convention discussed out there? Should we only use one? If so which one, and if not, how should we choose?
...
I want to know if there is some technical name for those regions of extra memory that are allocated for debugging purposes and filled with special patterns, so they can be checked at runtime to see if have been overwritten (and thus detecting a possible buffer overflow)...
A fellow referred to them as "Canarios" (Canaries in Spanish), I...
When collecting requirements from business users, I run into a point where I need to understand the cardinality between two concepts in the business user's domain.
This is usually something I want to know early in the process, since it affects database design which is hard to change later.
For example, the busines user may have a domai...
I'm going through all sorts of WPF documentation, and I'm feeling unnecessarily confused. The term 'business logic' is scattered throughout it, as if everyone should know what it is.
I can see what business logic is, according to this question here:
http://stackoverflow.com/questions/39288/what-exactly-consists-of-business-logic-in-an...
I think the subject says it all. I always call it the "arrow operator", but I'm sure it has an official name. I quickly skimmed the C++ standard and didn't see it mentioned by name.
...
I'm about to write a class called CurrentDate and need a solid package name. The obvious answers are com.destroytoday.date or com.destroytoday.time, but I'm not sure if I'll have more date-related classes in the future to justify an entire package. Are there any names I can use that would allow non-date-related classes in the future?
To...
I developed a static Console class that writes any traces, successes, and errors to a log file. It requires a file path String and a LoaderInfo instance to get started. At the moment, the function is named start(path, loaderInfo). I'm not really feeling the name "start", so I'm wondering if there's something more accurate. To me, start m...
I wrote a class that performs an asynchronous loop. It needs a package name. I already have a util package, but feel resistant to put half of my classes in that package. If it really belongs there, I'll put it there, but I'd feel much better if I can find a more appropriate/specific package. What do you think?
...
I'm writing a worksheet, and want to ask students to write a function that looks like this:
isPrime(int number)
What's that line called - manifest comes to mind, but I don't think that's it...
...
I wrote a loader class that has a tries property that indicates how many times to retry loading a url if an error code is returned. For instance with Twitter, the loader would retry loading a method call if a fail whale is returned, since the next call would probably return success.
I specify the many errors that can be dispatched with ...
Why did the creators of Java use the name "class" for the classes in Java? Where does this term come from?
...
I recently tried to understand a C++ program that was written by somebody who I assume had a background in functional programming: For example, he had declared a closure class which he extensively used and which does somewhat resemble what is known as a closure in functional programming. Another class was called a guard, but I haven't qu...