naming-conventions

Visual Studio CommandBar "Names"

In Visual Studio 2010, the only option you can create is a commandbar under "Tools" on the "MenuBar". In some cases, I would want to know how to place the command bar on the standard bar, or be found when I right-click a project file. Example: Microsoft.VisualStudio.CommandBars.CommandBar menuBarCommandBar = ((Microsoft.VisualStudio....

Naming Convention for Blackberry Development

I have gone through with some of the sample examples of blackberry. And in some classes I have found some variables are starting from _ like _address and some of them are ALLCAPS. So, i guess it's bit different then the basic Java naming conventions. So, can anybody let me know that is there any difference between Java and blackberry ...

Naming convention for getters/setters in Java

Hi guys, if I have the following private member: private int xIndex; How should I name my getter/setter: getXindex() setXindex(int value) or getxIndex() setxIndex(int value) EDIT: or getXIndex() setXIndex(int value); ? ...

Proper color names from colordialog

Whenever I run this, and open the color dialog, there are many colors that do not having a proper name, the listbox will show something like "ffff8000"(Orange-Yellow). Is there another way of pushing the proper name? Is there a proper Color Name library I can reference in code? colorDialog1.ShowDialog(); cl.Add(colorDialog1.Color...

domain modeling naming problem

Hello There are some simple entities in an application (e.g containing only id and title) which rarely change and are being referenced by the more complex entities of the application. These are usually entities such as Country, City, Language etc. How are these called? I've used the following names for those in the past but I'm not sur...

What is the accepted pattern for naming methods that return Tasks?

APM uses BeginXXX/EndXX pairs and the Event-based Asynchronous Pattern (EAP) uses XXXAsync and XXXCompleted pairs, but I haven't seen anything standard on how to name methods that return a task. I have been using XXXTask: Data GetData() Task<Data> GetDataTask() but was wondering if a more standard approach has developed ...

What do I name this class whose sole purpose is to report failure?

In our system, we have a number of classes whose construction must happen asynchronously. We wrap the construction process in another class that derives from an IConstructor class: class IConstructor { public: virtual void Update() = 0; virtual Status GetStatus() = 0; virtual int GetLastError() = 0; }; Ther...

Naming conventions for complex getters in Java

Hi there! I was reading this MSDN article about the usage of properties and methods in .NET. It points out why and when to use properties or methods. Properties are meant to be used like fields, meaning that properties should not be computationally complex or produce side effects. Otherwise one should use methods. I was as...

Name Interface conventions when name already start with capitalized letter

Let say I want to create an interface for a class that should be name JQuery. If this class is an interface, from the conventions, I should name it IJQuery, but I find it's made the name look weird. What you think ? ...

On C# naming conventions for member variables

I have seen an advice somewhere here on SO to not name private/public member variables, in a way that they differ only by the case of the very first character. For instance: private string logFileName; public string LogFileName { get { return logFilename .... and: private System.Windows.Forms.MainMenu mainMenu;...

Naming conversion functions

Which naming convention for conversions is standard across most languages? convert_from_typea_to_typeb(arg) or convert_to_typeb_from_typea(arg) Or is there another standard? ...

JavaScript and PHP filename coding conventions

Hi, I would like to know the popular ways of naming files in JavaScript and PHP development. I am working on a JS+PHP system, and I do not know how to name my files. Currently I do for JS: framework/ framework/widget/ framework/widget/TextField.js (Framework.widget.TextField()) Framework.js (Framework()) So, my folders are lowercase...

How to get shared library names like ``libhello.so.0.0.1'' with scons?

I'm using the scons utility to generate shared libraries. When I write the following rule: SharedLibrary('hello', 'hello.c') I would get the ``libhello.so'' file. Is there a way to get files like ``libhello.so.version'' automatically? ...

MVC: Display objects : best practices?

Hi Guys, Inside a ASP.Net MVC 2.0 project I'm facing a few naming convention issues. For display purposes I'm using a few object residing in my Model directory inside the MVC Web Project: Object: CatalogView : Sort of wrapper object to group all objects I need for the catalog view (aspx) --- ShoppingBagPartialView ...

Incremental variable naming convention like i, but for an inside For statement?

Hi experts. This is the example: for(int i = 0; i < 10;i++) { for(int ? = 0;? < 10 ; ?++) { } } I usually use an "o" for the second loop, but is there any standard out there? ideas? Thanks. ...

How do you name member variables in VB.NET?

I am generally not one to engage in subjective arguments over matters like variable naming, code formatting, etc. So I have no intention of starting an argument here. I just came across this (old) blog post which recommends not prefixing member variable names: Do not use a prefix for member variables (_, m_, s_, etc.). If you wa...

Naming conventions and the Android SDK

Is there a publicly available document explaining the naming conventions followed in the Android SDK? ...

XRef vs Xref (.NET naming)

Which name is more consistent with .NET naming standards for properties and methods? 1. public string XRef { get; set; } 2. public string Xref { get; set; } ...

URL naming conventions

So, this may be a can of worms. But I'm curious what your practices are? For example, let's say your website consists of the following needs (very basic): A landing page An information page for an event (static) A listing of places for that event (dynamic) An information page for each place With that said, how would you design your ...

Why isn't the SQLiteOpenHelper called just SQLiteHelper?

The documentation describes the class as a helper object to create, open, and/or manage a database. Having that in mind wouldn't you say that the name is a little misleading? ...