I am working on a web application with a couple of colleagues for the moment. It have turned out that we all have our own way of naming the classes, methods or whatever functions that we currently are writing.
This is starting to get really annoying already so I know that we have a iceberg ahead if we continue like this.
Obviously the ...
Hello, help me please with naming vars and functions!
And more specifically about standartizing names and functions (I'm not talking about classes because sometimes it really depends on FrameWork etc.).
For example: list, map, counter/count (or cnt), quantity (or qnty) etc.
I'm asking because sometime it is really difficult for me to ...
I like to give my variables, methods and objects descriptive names. Obviously not going overboard, but let me give you a couple of examples.
public class Account
{
public decimal Balance { get; set; }
}
Account account = new Account();
account.Balance = 1000;
Some people would opt to go for the following, which really does not ma...
I am embeding SpiderMonkey (mozila javascript) interpreter/engine in my C/C++ application. i programatically loading a javascript script and want to test (from my C/C++ code) if a certain function exist/defined in this script.
is there a way to do that ?
maybe a way to list all functions in a given script ?
Tnx,
Vertilka
...
I have a class which is called TestPlan (to put it simple, let's assume that it's a usual java bean).
I need to store TestPlan instances in xml-files (1 instance per file). The most appropriate way to do it which I can see is using another class which should do only xml-related work.
It'll have methods like:
public TestPlan parseTestP...
I have a problem, where I have two third party libraries classes that I have to extend and use together. But both have the same naming convention and two class name end up having the same name.
Since I cannot extend two classes, I don't know how to fix them, how to create a wrapper against one. I cannot use PHP Namespaces as the PHP ver...