Difference between classes java.rmi.Registry and java.rmi.Naming
What is the difference between the Registry class and Naming class. In my application I am using Registry class. But I want to know about Naming class and its uses ? ...
What is the difference between the Registry class and Naming class. In my application I am using Registry class. But I want to know about Naming class and its uses ? ...
I'm using Subsonic 3 (Active Record), VS2010, Framework 3.5 against a MySQL database. Someone named a column "string." I S@*t you not. OK, I've named some database objects some dumb names (Like naming a SQL Server table "User") before but... c'mon! And I cannot change the table because of dependencies in the app! OK I feel a little b...
The title says it all... ...
You've got an N-tier application which deals with companies, so you've got a table called Company, an object in your DAL called MyApp.DAL.Company, an object in your application layer called MyApp.Core.Company, and in your service contract called MyApp.Contract.Company, and in your client proxy called MyApp.ServiceReference.Company, and i...
Hi folks, I'm looking for words that can be created from hex alphabet [0-9a-f]+ like C0FFEE, DEFACED We also can use lisoz, where 1=l,i; 5=s; 2=z; 0=o etc. It can be used in memory addressing or IPv6 address, so it will be funny and much easier to remember. There is nice list here: http://www.nsftools.com/tips/HexWords.htm but I'm sure...
I'm in a situation where a module I'm using has a function that's name is exactly the same as one in my own module. When I try to call the function in my module (OO Perl, so $self->function) it's calling the function from the other module instead. I've already got around it by renaming my function but as a matter of interest, is there a...
If I have a method that hides a button, I would probably call it HideButton If I have a method that shows a button, I would probably call it ShowButton But what do you guys call a ShowIfThisHideIfThat style method? Possible Choices: TestForButtonVisibility (this kind of sounds like it will return true/false but not actually do the wo...
I need to name this structure: struct NameNeeded { DateTime timestamp; float value; } I will have arrays of this struct (a time-series). I'd like a short and suggestive name. The data is financial (and Tick is not a good name). The best one I can think of is DataPoint, but I feel that a better one exists :) How would you na...
How should the naming go for colunms used systemwide. For example city. In city lookup table the colunm is called city_id, city_name. Now city is used in other places like events - I have called it event_city which refers back to city_name. Then in user profile there is user_city which again does the same. Should these all be called the ...
I'm tasked with choosing a name that will in effect be the internal name of our architecture. I'm taking this responsibility seriously, as I have worked with a lot of "bad" namespaces and don't want to inflict one on others. What makes a "bad" namespace to me? In terms of human factors: An acronym that is essentially meaningless: DDL...
Hello! I'm trying to implement my own Hibernate NamingStrategy based on the ImprovedNamingStrategy. This is quite nice... only the foreign keys of many-to-many relations are ugly. Example scenario: public class Teacher { @ManyToMany private Set<Course> courses; } public class Course { @ManyToMany private Set<Teacher> ...
Bit of a newbie question, but I'm unfamiliar with Java. I'm thinking either: com.company.webservices or com.company.webserviceretriever or com.company.webservice.retriever Any thoughts or opinions on the matter? ...
Imagine a function that deletes a cookie and returns its value. What would you call it if you have to use a single verb? I called it clear but I'm not very fond of the name. ...
If the answer is yes, can you tell me why? here is an example: namespace urx { struct reserved { }; struct side { urx::reserved reserved() { /*...*/ } }; } int main() { urx::side side; side.reserved(); } reserved is used for both a type name and a function name. side is used for both a type name and a variable name. b...
Hello, I have a problem naming the elements in my application's data model. In the application, the user has the possibility to create his own metamodel. He does so by creating entity types and a type defines which properties an entity has. However, there are three kinds of entity types: There is always exactly one instance of the ty...
If I have a class that stores a DateTime: class LogEntry { readonly DateTime dateTime; public LogEntry(DateTime dateTime) { this.dateTime = dateTime; } public DateTime ????? { get { return dateTime; } } } What should I name the DateTime property? Or should I sp...
I'm about to create a User class for my project. Any opinions as to whether it is bad practice to create such a commonly-named class? I could complement it with a prefix specific to my project. ...
hi guys i want a cool and geeky nickname and i cant figure out one so i thunk here is the right place to ask pls brain storm and get something good thanks to be understandable ...
This is a difficult one, I've been racking my brains but I just come up with a sensible name for these variables. Someone will probably instantly hit on one. Take these example actions: "throw bottle at wall" "push John into door" "attack Ogre with sword" action thing at/with/on/in/to thing I need a sensible name for the first "thi...
I want to name a variable using values of other variables given in a function. So, if I have values for an x1,x2 I can make the new variable's name as: x_(x1's value)_(x2's value) as a name. I've checked out the eval, num2str, strcat functions, but as of yet I can't make it so that I have a variable with the name above which I can assi...