naming

Long variable names

Lets say i have a variable that contains the number of search engine names in a file, what would you name it? number_of_seach_engine_names search_engine_name_count num_search_engines engines engine_names other name? The first name describes what the variable contains precisely, but isn't it too long?, any advice for choosing variable...

Does an app name have to be unique between the iPhone and iPad app store?

If there was an iPhone app called 'gears' could I release a app for iPad called 'gears'? Also, has anyone heard if Apple will move towards limiting unique names to a category so it would be possible e.g. 'gears' the game and 'gears' the productivity app? App naming seems like a dark art. Any pointers to resources on Apple's stance woul...

Problem Naming an Interface

I have an interface named PropertyFilter which used to take a Propertyand decide if accepts it or not. And the world was good. But now the interface changed, so that implementations may choose to add additional Propertys. For example a Customer property might get expanded into Name and Address properties. I think it is obvious this is...

How do you name member variables in VB.NET?

I am generally not one to engage in subjective arguments over matters like variable naming, code formatting, etc. So I have no intention of starting an argument here. I just came across this (old) blog post which recommends not prefixing member variable names: Do not use a prefix for member variables (_, m_, s_, etc.). If you wa...

What causes Apache Environment Variable set using mod_rewrite to have "redirect_" appended to name?

I am trying to set Apache environment variables (for use in PHP) with the [E=VAR:VAL] flag on RewriteRule rules in an .htaccess file. I have already discovered the variables are accessed in PHP as server variables $_SERVER rather than $_ENV (which makes a certain amount of sense). However, my problem is for some rules the [E=VAR:VAL] fl...

How would you name...

Since naming is a so important thing in programming, I would like to start a thread for giving help to all those that have same problems as I sometimes. Rules: Set a post with the description of the form||control||class or whatever you need to find a good name for. Get name hints in the answers. ...

Naming of an algorithmic antipattern

Hi, I'm having problems to recall the name of doing something with quadratic complexity when it can be solved linearly. For example, using a get-by-index function to iterate over a linked list instead of just using a next-element is the typical case of this antipattern. I think it was the "something painter", as a metaphor of a guy tha...

The best way to name tables

hi just a quick question, is it better to use underscore whilst naming tables or is it better to use camelcase. example table_name or tableName which one is better? and if there is a reason to be using either what is it? many thanks. ...

Naming conventions for persistence layer: DAO vs Manager vs ... ?

DISCLAIMER: I'm almost sure that I've seen the same question before but I can't find it now. If someone finds that question, please, give a link. I heard at least two opinions on the best name for classes which implements CRUD operations: someone says that DAO is a classical name and everyone knows what it means, but others say that Man...

Programmers dictionary/lexicon for non native speakers

I'm not an English speaker, and I'm not very good at English. I'm self thought. I have not worked together with others on a common codebase. I don't have any friends who program. I don't work with other programmers (at least nobody who cares about these things). I guess this might explain some of my problems in finding good unambiguous ...

Difficulty in naming functions

Possible Duplicate: Anyone else find naming classes and methods one of the most difficult part in programming? Sometimes it seems i cant really find any name for a function i am writing, can this be because the function is not cohesive enough? What do you do when no good name for a function comes to mind? ...

Product naming convention for iPhone 4 apps?

With the iPad we got applications with the product name extension "HD" to distinguish them from their low resolution iPhone counterparts. But, now with iPhone 4 also being an "HD" device, how to correctly name your apps? Basically I'd like to publish a game in three flavors: iPad, iPhone 4, and all other iPhone/iPod devices. Any though...

How do I avoid namespace and class name collision in "vertically partitioned" assemblies?

By "Vertically partitioned", I mean having namespaces named after modules rather than "layers" So, MyApp.Core MyApp.Accounting MyApp.OrderManagement MyApp.HR instead of, MyApp.UI MyApp.Business MyApp.Data The only issue I am running into is that sometimes those assemblies might have a part of the namespace that is same as a ...

Application name for project maintenance tasks implementation

There was a discussion (windows service or task scheduler) about maintaining projects. Personally I prefer a console application on task scheduler. I wonder what is the best thing to call such applications? The last team I took part in used the title JobMachine, but is there a more appropriate name for such an application? ...

What's the name of names like i18n, log4j, c14n ?

Hi, I know that i18n -> i nternationalizatio n (18 letters), log4j -> log for java (4 -> four -> for), c14n -> c anonicalizatio n (14 letters), and so on. What are the names of these natural langages techniques ? It's sort of rebus, puzzle, jokes ? Is there some doc on that ? Thanks. ...

Name for a bitmask with 1-bit set

In C and embedded, one frequently uses enumerated constants where every value is a bit mask with exactly 1-bit set. (e.g. 0x0001, 0x0002, 0x0004, etc.) Is there a standard name for this type of bitmask? I've seen them referred to as flags, but more in passing than as a standard definition. I know it sounds snobbish, but "flags" doesn't r...

Dummy implementation design pattern name

To avoid NullPointerExceptions I find it useful to provide an immutable dummy implementation of an interface together with the interface. Like this: public interface Action { void perform(); public static final Action dummy = new Action() { public void perform() { /*nothing*/ } }; } Action.dummy can then be us...

Iterating variables to change its features in Python

I assigned values with setattr() function in a loop: for i in range(30): for j in range(6): setattr(self, "e"+str(i)+str(j), Entry(self.top)) , then I want to apply .grid() func. to all these variables with a loop. For example, self.e00.grid(row= 0, column= 0) How can I do that? ...

Name for a "model and view" object?

Spring MVC names objects that contain a logical view name and the payload to render ModelAndView, the JAX-RS implementation Jersey names them Viewable. I like Viewable a bit better, but maybe you have a better suggestion. Example: return new Viewable("index", payload); How would you name a class, that combines a view (template) name ...

Wordpress Gallery Name Stucture

Hey guys, This website annapogossova.com is set up through wordpress. As you can see each "gallery" is set up as a page, with an iFrame linking to the actual html gallery. The problem is - Anna would like to call each item in the drop down menu - Gallery 1, Gallery 2, Gallery 3 etc.. This would be horrendous to manage as each pa...