naming

SOAP Web Service method naming conventions

Consider a Web Service (e.g. SOAP-based) that has an operation which accepts a bulk of data from the client. From the server's point of view it is receiving data, but from the client's point of view it's sending data. How should that operation be named? The options are ImportData ExportData / SendData Is there a de facto standard for...

Name my class: Pipelined cache? AntiSymetricPipelineCache?

Having trouble coming up with the right name for this class. Basically its a wrapper around a redis data store where writes are "fired off" asynchronously and performed on another thread (to keep the main processing behavior as fast as possible). There are only occasional Get operations and before we can run those we need to make sure th...

Can I use Ninject ConstructorArguments with strong naming?

Well, I don't know if "strong naming" is the right term, but what I want to do is as follows. Currently I use ConstructorArgument like e.g. this: public class Ninja { private readonly IWeapon _weapon; private readonly string _name; public Ninja(string name, IWeapon weapon) { _weapon = weapon; _name = ...

Recycle a project name?

I want to start an open source project, but my favourite project name was already used for a framework with the same goal. This project was never popular, there is nothing to download or executable, the project had only two active days with commits at Google Code and is dead since four years. In other words: the project is irrelevant but...

resharper naming rules for xaml namespaces

In Resharper 5.0 when I use a type in XAML that I don not have a nampsace include for yet, it automatically adds the namespace as follows: xmlns:ViewModel="clr-namespace:MyNameSpace.ViewModel" How can I force it to use abreviations like this: xmlns:vm="clr-namespace:MyNameSpace.ViewModel" ...

Function naming: sendCharacter or receiveCharacter?

I'm trying to name a function that runs when a character is received by the object. For the caller, it should be named sendCharacter, so that it can call: object->sendCharacter( character ) ; That looks nice for the caller.. but for the receiver, it implements a method /// Called when this object is do something /// with a character...

Is it kEatSpeed or kSpeedEat?

I have a bunch of related constants that are not identical. What's the better way to name them? way #1 kWalkSpeed kRunSpeed kEatSpeed kDrinkSpeed Or, way #2 kSpeedWalk kSpeedRun kSpeedEat kSpeedDrink If we evaluate these based on readability understandability organization in member list (autocomplete) not bug prone with subt...

Misc. Naming: Can I place underscores instead of camel casing in modern languages?

Hi! I would like to ask some kind of permission (I hope that doesn't sound strange) from the people who have influence on the naming conventions in modern languages like F#, Scala, etc. My problem is - I just can't read camelCased code and wish I could write underscored_names at least in my internal implementations (not in API interfac...

Calling javascript method from from inside object

I am struggling with methods in JavaScript. obj = function(){ this.getMail = function getMail (){ } //Here I would like to run the get mail once but this.getMail() or getMail() wont work } var mail = new obj(); mail.getMail(); How do I make the method in a way that I can run it both inside the object and from the outs...

Naming a method that converts raw data into an object

Say you have data in the format: name=john;age=33;gender=male What would you call a method that converts data like that into an an object / associative array? I've been thinking about: - unserialize_variables - parse_variables ...

Is there a term for this concept, and does it exist in a static-typed language?

Recently I started noticing a repetition in some of my code. Of course, once you notice a repetition, it becomes grating. Which is why I'm asking this question. The idea is this: sometimes you write different versions of the same class: a raw version, a locked version, a read-only facade version, etc. These are common things to do to a ...

dynamic naming of UIButtons within a loop - objective-c, iphone sdk

Dear Members, Scholars. As it may seem obvious I am not armed with Objective C knowledge. Levering on other more simple computer languages I am trying to set a dynamic name for a list of buttons generated by a simple loop (as the following code suggest). Simply putting it, I would like to have several UIButtons generated dynamically (wi...

Naming Unit Tests that just calls a constructor?

I'm trying to follow Roy Osherove's UnitTests naming convention, with the naming template: [MethodName_StateUnderTest_ExpectedBehavior]. Following this pattern. How would you name a test calling a constructor? [Test] public void ????() { var product = new Product(); Assert.That(product, Is.Not.Null); } ...

Naming Suggestions For A Function Providing Chaining In A Different Way

I've coded an experimental function which makes passed objects chainable by using high order functions. It's name is "chain" for now, and here is a usage example; chain("Hello World") (print) // evaluates print function by passing "Hello World" object. (console.log,"Optional","Parameters") (returnfrom) // returns "Hello World" I...

Trouble deciding return type of a method that returns a SortedSet

I am supposed to make a class that should be a container for an interval of values (like in mathematics). I have already decided that I'll use internally a SortedSet. One of the the things I'm supposed to implement is a method that "gets an ordered set with all the elements in the interval". class Interval { private SortedSet sort...

Large Scale VHDL modularization techniques

I'm thinking about implimenting a 16 bit CPU in VHDL. A simplish CPU. ADD, MULS, NEG, BitShift, JUMP, Relitive Jump, BREQ, Relitive BREQ, i don't know somethign along these lines> Probably all only working with 16bit operands. I might even cut it down and use only a single operand and a accumulator. With Some status regitsters, Carry, Ze...

How is the concept of "content negotiation" called outside the HTTP context?

Hello, everyone! What are different terms for "content negotiation" (when not talking about HTTP)? For example: some (remote or local) services, components, modules, are negotiating about which protocol to use and/or which content type to exchange. Service provider About the content: What I am very good at, is providing apples. I a...

What do we call this?

I'm wondering what do we call this kind of assignment. <?php class SimpleClass { public $var1; public $var2; public $var3; public function SimpleClass() { $this->var1 = 'one'; $this->var2 = 'two'; $this->var3 = 'three'; } } function test() { $objSc = new SimpleClass(); $objSc->va...

Is naming a software product the same as [someone else's] book legally problematic?

I came up with a name for a software product I'm developing. It's composed of two common English words put together (for example, Firefox, Silverlight, etc.). I Googled the name to see if it was being used by any other software product before committing to it. After finding none, I did notice that there is a book published around 60 year...

How to organize SQL script files & folders

We have an Oracle 10g database (a huge one) in our company, and I provide employees with data upon their requests. My problem is, I save almost every SQL query I wrote, and now my list has grown too long. I want to organize and rename these .sql files so that I can find the one I want easily. At the moment, I'm using some folders named a...