naming

.NET valid property names

Where is the documentation for valid property names in .NET? Obviously things like space, * or & aren't valid in a property name, but where is this documented? ...

How to name variables that represent thresholds or limits?

For example, say we have a ticketing system that can be configured to offer tickets at normal price, but once you're within X hours of the event, you offer them at a different price (it may be discounted or increased). We'll call this the 'rush price'. Moreover, once you're within Y hours of the event, you offer them at yet another price...

Language of variable names? (native foreign language speakers)

We are a spanish speaking development team, we code in django and we all are pretty fluent in english, as all documentation, sample code, APIs, etc come in english. On our last project we chose to name all the variables, class names, modules, files and such in english, even though the whole application was in spanish, we kept a strings ...

Opposite of "Abstractor"

I have a function that takes object instances and reduces them down to an abstract/generic format. Like this: class Dog { id=0, awesome=1 } => [id:0, type:'dog'] //abstract, generic version class Cat { id=1, awesome=0 } => [id:1, type:'cat'] class Narwhal { id=42, epic=1 } => [id:42, type:'narwhal'] I call this an abs...

How to deal with changing feature and product names in source code?

What is a good strategy for dealing with changing product and feature names in source code. Here's the situation I find myself in over and over again (most of you can relate?)... Product name starts off as "DaBomb" Major features are "Exploder", "Lantern" and "Flag". Time passes, and the Feature names are changed to "Boom", "Lighthous...

Alternate name for BackingStoreException

I'm about to undertake the task of abstracting out all SQLExceptions from an ORM's public interfaces with something more generic - that is declaring a generic exception which would in most cases wrap say an SQLException), and I'm wondering about naming. I'm thinking of something along the lines of BackingStoreException or StorageMediumE...

Saxon Genitive in Naming Conventions?

What do you call your functions when names that contain a saxon genitive like "Verify Task's Priority" and "Change Argument's Priority" or "Increase Action's Delay"? Do you drop the apostrophe? verifyTasksPriority(), changeArgumentsPriority(), increaseActionsDelay() Do you drop both the apostrophe and the "s"? verifyTaskPriority(), cha...

Is there a standard name for this function?

What would you name a function that takes a list and a function, and returns True if applying the function to all elements gives the same result? def identical_results(l, func): if len(l) <= 1: return True result = func(l[0]) for el in l[1:]: if func(el) != result: return False return True Is there ...

How can I name Tuples?

Is there a language agnostic algorithm to name tuples? Specifically, I want the following function: 1 => Single 2 => Double 3 => Triple 4 => Quadruple ... 10 => Decuple ... 100 => Centuple First of all, is this human-language independent? For example, will that be understood in Spain and Russia? Secondly, what is t...

What is the official name of a class that must be inherited from to instantiate?

In OOP terms what is the name of a class that is always a parent, and the class cannot be used on its own, it can only be used if a class inherits from it. I don't need code samples, just the technical OOP term for this class, thanks! ...

SQL Server 2008 resolving localhost to a computer name

We're in the process of switching from Windows Server 2003 to Windows Server 2008, and we've encountered a frustrating problem: In the old environment, some developers used sql server 2005 and others used sql server 2008. No problems. Our connection strings all pointed to: localhost/sqlserver. Now, on the new Server 2008 environment, Sq...

Designing a class with **Exceptions**

When I design a class I often have trouble deciding if I should throw an exception or have 2 func with the 2nd returning an err value. In the case of 2 functions how should I name the exception and non exception method? For example if I wrote a class that decompresses a stream and the stream had errors or incomplete I would throw an exc...

Naming decision: "Create it if it doesn't exist" in one word

Exact duplicate of http://stackoverflow.com/questions/1238386/function-name-for-creating-something-if-its-not-there-yet I have a function which checks if a certain thing exists, and if not, creates it. What would be a good word for it? Right now I'm using "maintain", so the function is called maintain_buffer_on_path, but I think that...

Why ReSharper offers a variable name with a "class" suffix?

Hi guys, I was wondering why R# offers a variable name with a "class" suffix? When I am creating an instance of a class, why would I put a class suffix of my instance? Can there be any reason to have a such thing: BusinessClass myBusinessClass = new BusinessClass(); Thanks. ...

How do I name this simple method?

First of all, this is not really a programming question. It's more a question of "how do I satisfy McConnels naming conventions?" I have this Delphi-application that manipulates word-documents. One of the things I need to do is run through all the bookmarks in the document and delete some of them based upon a simple rule: If I currently...

Is it acceptable to use role based controllers in a MVC framework

If my site has several user roles say Admin, User, Manager and there are several modules of functionality that may be used by one particular user or by all users how should I go about naming my controllers? Is it OK to have role based controllers such as an Admin, User and Manager controller as well as controllers for shared functionali...

What should I name this Extension method ?

I have written an extension method for string manipulation. I'm confused what should I name it - since this will become part of the base library front-end developers in the team will use. Here's the profile of the class member. Info: Utility Extension method for String types. Overloads of this method may do the same thing characters oth...

Why name threads in .NET?

I've always been in the habit of naming my threads like this because I read sometime to do so, but it occurred to me that I've never used any debugging tool that showed a thread's name. When would naming a thread be useful? When would I actually see the name of a thread? Should I name threads for some profiling tools? What tools? ...

What to call the intermediate layer of the program?

We have a program consisting of three parts. There's the backend which is the NT service handling the requests. Also there's a COM object that implements a predefined interface, is consumed by client software and passes the requests to the service. Since we need to have both 32-bit and 64-bit versions of the COM object we split it into...

naming a finance management / tracking application

I am about to start develop a finance/expenses tracking/management/statistics webapplication, somewhat similar to xpenser.com , mint.com (except bank integration), for a college project and I am looking for a name credit will be given in the documentation if the name will be used if this turns later into a real-life project the name wi...