I am often in a situation where I have a concept represented by an interface or class, and then I have a series of subclasses/subinterfaces which extend it.
For example:
A generic "DoiGraphNode"
A "DoiGraphNode" representing a resource
A "DoiGraphNode" representing a Java resource
A "DoiGraphNode" with an associated path, etc., etc.
...
I was thinking, that all of my projects have boring names. For example, if making a math library, I'd call it math. Sometimes, I would add a prefix with my initials, so it'd become pmmath or *pm_math*. Boring, isn't it?
How do people come up with fun or at least, less boring names? Like Apache, Python, Ruby... They're not boring. If you...
Indexes and Constraints in MS SQL Server are local to the table they are defined in. So you can create the same index or constraint name in more than one table with no trouble.
Foreign Key Constraints (which as everyone should know are NOT keys, but constraints) will appear in the Keys subfolder and their names appear to be globally sc...
Is a machine WORD always the same or does it depend on the machine architecture?
And is the meaning of the word WORD context sensitive or generally applicable?
...
Guys,
[question update according to updated requirements]
I've implemented following function which should return either first not null element or throw an exception.
Also could you invent more classic and shorter name like 'max', 'min', 'pair'?
template <typename T>
T select_first_not_empty( const T& a, const T&b )
{
static T null...
What's the technical term for a computer-friendly name of an entity: e.g. "Guns N' Roses" becomes guns_n_roses. This has nothing to to with escaping or sanitizing input, but with aesthetics - looking good in an url.
To clarify, in an "questions" table, you might have the following fields
Title: Computer-friendly name for entity
Body: ...
Hi, I'm writing a Range class at the moment and I'm looking for a good name for the common range [0->1]. If it was a vector of length 1, I would call it a Unit vector. Is there a clear name to give this range/interval? Possibly a Unit Range?
...
Is there a valid math term? I could just name this guy "sumXY", but that is (a) lame, and (b) not scalable, since going up a dimension would require a rename.
While typing I thought of "componentSum", but I'd love to know if there's a real name for it.
...
Most programming code, I imagine is written in english. But I'm curious how people handling the issue of naming herein. Alot of programming is done within some bussiness domain, usually with well established terms for certain procedures, items.
I'm from Denmark for instance, and something I work alot with has a term called "indblikskod...
I tried creating a model called "class" (as in a graduating class of students), and encountered all kinds of problems. What are some other words or class names to avoid in Rails?
Some links I've found:
http://juicebar.wordpress.com/2007/05/30/reserved-words-in-rails/
http://railsforum.com/viewtopic.php?id=22242
...
Is there a max length for class/method/variable names in Java? the JLS doesn't seem to mention that. I know very long names are problematic anyway from code readability and maintainability perspective, but just out of curiosity is there a limitation (I guess class names might be limited by the file system maximal file name limitation).
...
Allright, doing some project with few friends, and I need some standard for naming things in c++. Does anyone have any good naming scheme for c++ that is well thought-out and not made in like 10min.
Example, int* house should be named int* house_p, so that when someone reads the code, he doesn't need to scroll all the time wondering if ...
Hey guys, a couple of us are looking for a collaborative name to work under when developing OpenSource products. The first of which will be an MVC CMS which is designed to be as usable as possible (no admin system all editing done inline).
So can you help us name the two:
OpenSource Organisation - mainly dealing with .net and mvc solu...
I'm looking for ideas/suggestions on a namespace.
I have 3 objects that do the following:
Object 1: Reverse Phone Lookups
Object 2: Reverse Zip Code Lookups
Object 3: Reverse IP Address Lookups
Currently, they are in the following namespaces:
(CompanyName).Utilities.PhoneTools
(CompanyName).Utilities.AddressTools
(CompanyName).Uti...
I have been trying to clean up the naming and organisation conventions of our projects' unit and integration tests. We are using C#, NUnit, Visual Studio and Resharper.
It seems that if there is one best practice for unit test organisation it is that the layout and naming of the test classes and namespaces should mirror those of the cod...
Hi,
Can I use partial classes to create properties that points to an association property generated by the L2S designer. Also, will I be able to use the new property in queries?
How can I achieve this?
...
I try to be grammatically correct in my naming*. I've always used filename instead of file*N*ame. The java convention also seems to use this, but FxCop prefers fileName.
There's a discussion on WikiPedia about it. The more I read, the more I feel I'm right (which is quite usual! :) ). Does anyone have a definitive answer or is this ...
By user-level abstraction I mean what should I call them and what kind of icon should I use to represent it in the UI? The concept of tags should be familiar to most users right now, but I'm not so sure hierarchical tags are, nor does the abstraction of tags completely fit.
What I have is actually something between folders and tags, in...
Which is more correct, "PriceList" or "Pricelist"?
FxCop says:
CA1702 : Microsoft.Naming : The compound word 'PriceList' in type name 'PriceList' exists as a discrete term. If your usage is intended to be single word, case it as 'Pricelist'.
Edit: This is an object with Title, Start/End date etc.
...
I'm writing an Event Booking system in C#, which is vexing me greatly because "event" and "delegate" are reserved words. "Delegate" I've changed to "Attendee", but I can't think of an alternative name for the Event class (and instances thereof). The best I've come up with is "Happening", which is a little bit 1970s for my liking. Plus, t...